Error in minimization step “WARNING: too long bond”

Viewing 3 reply threads
  • Author
    • #25915


      Dear GENESIS developers and users,

      I am doing an MD simulation for a protein-membrane system. I created the GENESIS input files from CHARMM-GUI. However, my simulation is stuck at the minimization step with the following warning:

      WARNING: too long bond: 16391 16394 2.50874
      Setup_Fitting_Spdyn> NO fitting is applied, skip
      fitting method = NO

      I didn’t notice any error reported in the log file.

      I tried increasing the switchdist = 12.000, cutoffdist = 14.000, and pairlistdist = 15.500. But still can’t solve.

      Could you please help me explain the case and suggest me any solution to this problem?

      Thank you so much.

      Best regards,

    • #25916



      The message indicates that covalent bonds in your simulation system are too long. (It means that your simulation structure is very unstable, as like ring penetration.) Then, non-bond interactions and the parameters (switchdist, cutoffdist, pairlistdist) related to the interactions are not directly relevant.

      If there are the ring penetrations in your system, they can not be solved by running any simulations. Please read our site to solve it.

      I am also concerned that this warning does not promptly stop the job. If your simulation stops, it may be due to yet another error.

      Then, I recommend to compile GENESIS using debug option and double precision. ( please add –enable-debug=3) and execute your simulation.




    • #25919


      Dear Dr. Kobayashi,

      Thank you for your suggestion.

      I have added  –enable-debug=3 in my script as the following:

      mpiexec sh -c ‘inp=step6.0_min.inp; log=step6.0_min.log; if [ $PMIX_RANK == 0 ];then spdyn ${inp} > ${log} ;else spdyn ${inp} ; fi ‘ –enable-debug=3

      The job information file stated that  “==> Error: genesis@2.0.3 matches multiple packages.”

      I think the problem is there are 2 specs of GENESIS in the Fugaku system.

      Then I tried specifying 1 spec and executing my simulation again. I received an error related to cmap parameters. Therefore, I would like to create another post for this issue.

      Yours sincerely,


    • #25921



      I meant that you need to compile genesis (spdyn) by yourself instead of use binary of spack.

      (However, please change “–enable-mixed” to “–enable-debug” in “./configure” command.)

      I’m sorry for my poor explanation.

      (I have not prepared spack binaries with the debug option while I’ve prepared two binaries with mixed and double precision.)

      Thank you for your understanding.




Viewing 3 reply threads

You must be logged in to reply to this topic.